Лег аппач, из за неакуратных действий.

Тема в разделе "Администрирование серверов", создана пользователем wwizard, 25 июл 2020.

XEvil 4.0 Релиз Состоялся!
Модераторы: mefish
  1. wwizard

    wwizard

    Регистр.:
    20 июл 2009
    Сообщения:
    551
    Симпатии:
    15
    Конфигурация сервера - нужен совет

    При удалении папок пользователя и перезапуск - аппача, я удалил папки - к привязанным пользователям, и при перезапуске аппача, возникла ошибка:

    httpd not running, trying to start

    Теперь ни один из сайтов не работает. Нужен совет как исправить.
     
  2. Talay

    Talay

    Регистр.:
    22 июл 2009
    Сообщения:
    210
    Симпатии:
    43
    Обратно создай папки и файлы
     
  3. wwizard

    wwizard

    Регистр.:
    20 июл 2009
    Сообщения:
    551
    Симпатии:
    15
    эх - я не помню какие удалил(( не заскриншотил, думал мусор
     
  4. Горбушка

    Горбушка Ищу её...

    Регистр.:
    2 май 2008
    Сообщения:
    3.419
    Симпатии:
    2.371
    Открываешь конфиг Apache, смотришь пути, которые он смотрит - создаёшь пути или удаляешь их из конфига.
    А вообще он в лог должен писать какой папки ему не хватает...
     
    wwizard, MuayThai, metsys и ещё 1-му нравится это.
  5. stelz66

    stelz66 Постоялец

    Регистр.:
    16 апр 2012
    Сообщения:
    60
    Симпатии:
    6
    Конечно смотреть лог апача в момент попытки запуска,
    искать его примерно тут /var/log/apache (может быть наверно apache2) / error.log - примерно так
    вот найди этот файл, в одной консоли ssh запусти:
    tail -f /var/log/ (путь до имени файла ошибок)
    а в другой консоли стартуй апач, и скорей всего в первой консоли все увидишь
     
    Горбушка нравится это.